SP PRO Interactive Inverter Charger

Technical Note

Installation of Advanced communications
card and LG Chem RESU

Introduction
This technical note shows how to set up an SP PRO for use with an LG Chem RESU lithium battery (LG

RESU battery).
It explains how to update the firmware in the SP PRO, install the Advanced Communications card, install

the LG RESU battery and configure the SP PRO inverter to suit.
IMPORTANT:
1. You must update the SP PRO firmware with the Green card first.

2. Then install the blue Advanced Communications Card (ACC).

3. When connecting SP LINK via the USB port on the blue ACC, you must select
connection type “"Serial” NOT "USB” (see page 7).

4. Configure the LG RESU so you get 10min run time (see page 4 or 5).
Summary of steps
The following is a summary of the steps needed to complete the installation. Once the installation is
completed come back to this page and use this as a check list.

O Install SP LINK version 9.7 on your computer

O Connect to the SP PRO via the OLD green communication card using SP LINK 9.7

O Update SP PRO Firmware with 9.70.6 (ABB and Fronius) or 9.70.1 (KACO)

O Install the blue Advanced Communications Card (ACC) in the SP PRO

O Connect LG RESU batteries to the ACC in the SP PRO

O Create the configuration for SP PRO using the Site Configuration Wizard in SP LINK

O Connect to the SP PRO via the ACC (connection type “Serial”) and save the configuration to the
SP PRO

O Power cycle the SP PRO

O Test the system
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SP PRO Interactive Inverter Charger

Technical Note

Installing SP LINK and updating firmware in the SP PRO

The SP PRO firmware must be 9.70 or higher to function with the Advanced Communications card. So
you must first install SP LINK 9.7 on a computer, connect to the SP PRO and update its firmware. This
is done by following the steps below:

Status
Firmware loaded. Ready to send to SP PRO.

1. Leave the old green communications card in the SP PRO until the firmware is updated.

2. Download SPLINK program from the Selectronic Web site and install it on a Windows PC.
Windows XP, Vista, 7 and 10 are supported.
http://www.selectronic.com.au/sppro/splink.htm

3. Connect the DC power to the SP PRO. Wait until the front panel LEDs are stable.
NOTE: Perform the following tasks quickly as the RESU battery will shutdown in 10 minutes
without the CANbus connected. If this happens, turn the RESU back on and restart the process.

4. Connect the PC to the SP PRO via the USB cable.
Menu “File > Firmware Update”

6. In the SP PRO Firmware update screen click on the Update firmware and restart SP PRO on
completion.

7. After the update is completed the SP PRO will automatically restart. You will need to wait about
90s for the inverter to restart. AC output Power from the SP PRO will be lost during this time.

8. Once the SP PRO has restarted, wait another 20 seconds then click the Connect button to
reconnect SP LINK to the inverter.

9. Go to "Data View > Inverter Details” and check the Software Version is correct.

SP PRO Firmware Update - x Mow  Today DC History AC History Technical Data Inverter Details  Battery Manager
Current SP PRO Finweare Ifommation lr;vpegzo Model Control Board Serial Comms Card Serial
S;T:;Tr:l\reﬂerSupport: ﬁ.BE.SoIar. Fronius |SPMC432"'“‘U | |139?8T | |4660 |
Model: SPMCAB1. 48V DC. ScW. 240V AC SP PRO Ratings Control Board Revision Comms Card Revision
Control Board Serial: 144808 43V DC, 7,350, 290V AC |23 | |1 |
Comms Card Version: Mot Present
Comms Card Serial: Not Present SP PRO Serial Number Control Board Mod Status ~ Comms Card Mod Status
) [141419 | |

New Firmware Information
Version: 5706 5P PRO Revision Power Board 1 Serial Comms Card 5W Version
String Inverter Support:  ABB Solar, Fronius |21 | |‘|3B?97 | |ﬂ,1]5
Model: All models

Control Board Serial: All serial numbers 5P PRO Mod Status Power Board 1 Revision
Comms Card Version: 4

rd Serial:

Softwane Version Power Board 1 Mod Status

[3:708

After restarting, the SF PRO may appearto be off for up to 50 seconds.

Upload fimware String Inverters Supported Power Board 2 Serial

PRO Cancel
e " [ABB Solar, Fronius | [138749 |

Grid Connect SW Version Power Board 2 Revision
Advanced Options ... |2.Dﬂ | |“ |

5P PRO Total Run Time Power Board 2 Mod Status
[13207.2h | | |
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SP PRO Interactive Inverter Charger

Technical Note

Installing the Advanced Communications card (blue)
1. Power down the SP PRO inverter. All Lights on the front panel will be off. The three blue lights
across the top will still be lit if there is AC source power (grid or generator). This is OK.

2. Remove the 4 Torx screws holding the original green communications card in the SP PRO. Do
not through away the Torx screws, the screws will be used to remount the Advanced
Communications card.

3. Remove the 2 short grey RJ45 connectors from the Control Board in the SP PRO (Internal
Communications Ports 1 and 2)

Remove the white, 2 pin plug on the top right corner of the green communications card (Power)
Remove the original green communications card

Connect the white, 2 pin plug to the top, right corner of the blue Advanced Comm card (Power)

N oo vk

Connect the two, small grey RJ45 leads to the blue Advanced Comm card and into the Control
board in the SP PRO (Internal Communications Ports 1 and 2)

8. Screw down the blue Advanced Comm card into the SP PRO using the 4 Torx screws. (mounting
screw)

Power

Internal Communications
Port 1 and 2

Mounting Screws

SCERT Comms to
Adaptor board
(35 RS485-2)

LG Chem Comms Cable at - - 14
CAN bus e Y /g i

Mounting Screws

""" £301546
LUETCUN
1]

RS232 Port 1 for e | ‘ la ; \
Ethernet Adapt e TP e F—=" I
p \ - ‘.‘5‘ Q “ L E | %g ‘k AW \
w - e o i s i = BN el - L4
NOTE: For Rev 02 boards, connector labels are printed on the board either above or to the
right of the connector.

USB Port
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SP PRO Interactive Inverter Charger

Technical Note

1.

U

Connect the RESU comms to SP PRO (Single battery)
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The SP PRO battery temperature sensor remains connected to the SP PRO. Roll it up and place it
inside the SP PRO.

Do not connect any wires to the pre-charge/battery sense terminals. The battery sense voltage is
read from the RESU BMS.

Configure the RESU dip switches and rotary switches as shown below:

RESU BATTERY

CANL=2
GND =3
TermRes = both ON

CellSelect = Both OFF

SW Select - 1,2=0FF 3,4=0ON

Connect a R145 patch lead from the CAN on the blue Advanced Comm card to the RESU battery.
Power up the SP PRO by turning on the LG battery and any DC breakers.

After the SP PRO has powered up and the front panel LEDs are stable, check the green LEDs on
the blue Advanced Comm card.

a. The LH LED should alternatively turn off and on every second.

b. The RH led should be steadily on.
If there is a problem then disconnect the power from the SP PRO and go back to point 4.




SP PRO Interactive Inverter Charger

Technical Note

Connect the RESU comms to SP PRO (Dual battery with RESU Plus)
1. The SP PRO battery temperature sensor remains connected to the SP PRO. Roll it up and place it
inside the SP PRO.
2. Do not connect any wires to the pre-charge/battery sense terminals. The battery sense voltage is
read from the RESU BMS.
3. Follow the RESU instructions to install the RESU plus and the RESU battery banks.
4. Configure the RESU Plus rotary switches and RESU Battery settings shown below:

RESU PLUS

EnE. | ww )
caﬂ ~=~ ¢00 Zy & 200

P

TermRes = both ON
CellSelect = Both OFF
SW Select - 1,2,4=0FF 3=0ON

5. Connect a RJ45 patch lead from the CAN on the SP PRO blue Advanced Comm card to the RESU
Plus.
6. Power up the SP PRO by turning on the LG batteries, the RESU plus and any DC breakers.
7. After the SP PRO has powered up and the front panel LEDs are stable, check the green LEDs on
the blue Advanced Comm card.
a. The LH LED should alternatively turn off and on every second.
b. The RH led should be steadily on.
8. If there is a problem then disconnect the power from the SP PRO and go back to point 5.
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SP PRO Interactive Inverter Charger

Technical Note

Configuring the SP PRO for LG Chem RESU.

1. Run Selectronic SP LINK

2. Select “Site Configuration Wizard”

3. Enter the site name

4. Select “"Manual Configuration” (The Blue Adv Comm Card is not detected automatically as yet)
5. Select “SP PRO AU”

6. Selected SP PRO model which will be either "SPMC481"” or “SPMC482"

7. NEXT

[] Easy Start Guide x

Site Configuration Wizard

Step 1 of 4 - New Site Conneclion Details
Give the site @ unique name.

[RESU=d |

Plug the invarter into ths computer via the provided UISB lead, or continus
0 38t up a configuration manually and connact to the invarter later

(O Select a detected USB Device

<No devices detected>

(® Manual Configuration
Please select ether the SP RO AU or SP PRO GO senes

oo
|
O SP PRO GO
{On grid only)

SP PRO Mode! |SPMC481 v

Cancel Previous Next

8. Select “Standard Configuration and myGrid Kits"

9. Select the RESU model including number installed.
NOTE: The 2x RESUxxx selections are used when there are 2 RESU batteries installed with a
RESU Plus. If the 2 batteries are of different sizes, then select the largest Model. Eg. If a
RESUG.5 is combined with a RESU10 then select 2x RESU10.

10. NEXT

[%] £asy Start Guide X

Site Configuration Wizard

Step 2 of 4 - Select Battery Configuration
Battery Configuration
(@ Standard Battery Configurations and myGrid kits

myGrid MG0482A

Isthe battermyGrd MGO482A-1 bure. select Sedled

86kwWh

State Of Charge
SoC Support Limt (Generator Stat SoC for Off Grid)

60 13| % [35kWh | Support Battery Capacty

Inverter Shutdown SoC

0[] % [26kWh | Btra Backup Battery Capacty
Cancel Previous. Next

11. Continue through the wizard to enter other system parameters.
12. When completed, from the menu bar select File > Site Configuration > Save to save the site just
created.
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SP PRO Interactive Inverter Charger

Technical Note

Saving the Configuration to the SP PRO.

Connect the USB lead between the SP PRO and the PC.

. At the Connection Settings tab, select Connection Type = Serial

3. Select the COM port associated with the SP PRO. If unsure then unplug the USB lead from the
PC, and see which COM port number disappears. Plug the USB lead back in and the COM port
number will reappear.

N =

SP PRO Details Connection Settings  Components

v FndSPPRO |

Connect

4. Click the “Connect” button to connect to the SP PRO.
5. At the Configuration Settings tab, click the “Configure SP PRO"” button. The default passcode is

[EI Selectronic SP LINK beta 9.4.6242 - O X
File Connection PerformanceData Help Disconnected ” 00:00:00 “ ” H
Site Information  Configuration Settings  QuickView Data View Service Seftings
Configuration File {\\st\users\Ken\My Documents\New Config7.SPLC I Get SP PRO’s Configuration
Configure SP PRO
Quick Start
Unit Application Battery Type AC Source Power SoC Control Battery Capacity
[0.1-15.0 kW] [20 - 10000 Ah]
Solar Hybrid (On Grid) & BMS - LG Chem | 1502 [kw v Enabled v 126/2] [6.0kWh
Inverter Battery Charger AC Source Solar Hybrid Control System Inputs / Outputs  Shunts  Bxpansion Card Wiring Diagram
Digital Inputs Digital Control Analogue Control Generator Inputs Generator Outputs Alam Output AC Load Ouipuis Bdem. Regulator Outpuis
Lmvmﬂll[h-n Digital Control Input Analogue Control Input  Generator Remote Generator Run Output Alarm Output AC Load Energy Output  Exdemnal Regulator
Override Input Nane V| [Adoguewput | ‘artlneut Relay Output 1 v| | Relay Ouput 4 v|  [None V] Drass Oupu
None v None v Digital Control Output 2 v
Normal /Alternate AC Digital Control Output Input Assert Level Gonortor Available Generator Start Output ~ Alarm Type Energy Assert Level 73 .
Input Power Seleclor o ol | lo-s0v] 7] © Relay Output 2 v| | Mett + Shutdown 5| | [1-1000 k] - mmm Regulator
None ~ - = 70"‘“
Output State None e ABB Ground Fault Digital Control Output 1 +
Inhibit Export Input Input De-Assert Level AC Load Power Out
— Z1 [Follow v o-s0v Generator Low Fuel Alarm Output put
gfg] e None ~| [None v
Shutdown Input Control None hd Power Assert Level
Nene e Output Generator No Fuel 0.1-15.0 k4]
Shutdown Level o o lnput \ 10k
Active High ~ None ~
Generator Fault Input
None ~
< >
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SP PRO Interactive Inverter Charger

Technical Note

Testing the RESU battery.

1. Power cycle the SP PRO by turning off the DC breaker, wait 20 seconds and turning back on.

2. Navigate to “Data view > Battery Management”. If the system is working correctly the values on
this screen will be valid for the LG Chem RESU.

3. The Module Status readings are greyed out as they are not used with the RESU batteries. These
readings are only used when the LG Stand Alone (19” rack mount) battery modules are installed.

4. The values displayed under Battery Management are those read from the RESU battery.
The SP PRO uses these values to adjust the charge current and limit the discharge current in the

battery.
Site Information  Configuration Settings  QuickView Data View | Sarvice Settings  Factory Mode
Now Today DCHistory AC History Technical Data Inverer Details Battery Management Expansion Card Wiing Diagram  F
r;“e“’”mm”le"‘ | o || BisTne Note: The SP PRO will be beeping and
142A -52.2 A lodule
R S — o S the RESU battery will turn off (its breaker
57.7V 574V
Gmom  smdoms: [ will trip) after 10 minutes if there is a
09A 99.0 %
o gwwess Hordvere Voo problem with the communications
LG Chem 99.0 %
B S Made 5 between the SP PRO and the RESU
o Vodie & Ft 1St . battery.

Module 7

Module 8

Module 3

Module 10

Operation of the SP PRO with the RESU battery.

The SP PRO reads all the data out of the RESU battery bank and automatically adjusts the battery
current to suit. This means the operation is a little different than with other battery banks.

When connected to the grid the operation of the SP PRO is as follows:

1. When the SP PRO is charging the charge current will be limited to the “Charge Current Limit” as
displayed in Battery Management (see diagram above) and the charge voltage limited to “Charge
Voltage Limit”.

2. When the SP PRO is supporting the load then the current taken from the battery bank will not
exceed the “Discharge Current Limit”. The SP PRO will adjust its maximum support power to
ensure the discharge current is not exceeded.

When the grid fails then the operation of the SP PRO in stand alone is:

1. When the SP PRO is charging from the PV, the charge current will be limited to the “Charge
Current Limit” as displayed in Battery Management (see diagram above) and the charge voltage
limited to “Charge Voltage Limit".

2. When the SP PRO is running the load and the current drawn from the battery exceeds the
“Discharge Current Limit”, the SP PRO will go into current limit and reduce its output voltage. If
the load so high that the AC voltage drops below 200V for 10 seconds, the SP PRO will shut
down as the RESU battery can no longer support the load. The customer then needs to reduce
the load so that when the SP PRO retries, it can continue to provide backup power.
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